通达信主力短线副图指标公式(附源码破译和源码)

发布日期:2024-01-25 06:58    点击次数:192

编程思路破译

XA_1赋值:收盘价的5日简单移动平均

XA_2赋值:收盘价的10日简单移动平均

XA_3赋值:收盘价的60日简单移动平均

XA_4赋值:收盘价的120日简单移动平均

XA_5赋值:1日前的收盘价<1日前的XA_1 AND 开盘价<XA_1 AND XA_1>XA_4

XA_6赋值:1日前的XA_5=0 AND XA_5

XA_7赋值:1日内最高价的最高值的8日指数移动平均

XA_8赋值:收盘价的8日指数移动平均

XA_9赋值:XA_8<1日前的XA_8 AND 收盘价<XA_8

CA_10赋值:如果XA_7<1日前的XA_7ORXA_9,返回1,否则返回0

CA_11赋值:(统计4日中满足CA_10=1的天数=3 AND CA_10=0)*89

CA_12赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)

CA_13赋值:如果收阳线,返回CA_12*(最高价-最低价),否则返回如果收阴线,返回CA_12*(最高价-开盘价+收盘价-最低价),否则返回成交量(手)/2+如果收阳线,返回0-CA_12*(最高价-收盘价+开盘价-最低价),否则返回如果收阴线,返回0-CA_12*(最高价-最低价),否则返回0-成交量(手)/2

XA_14赋值:CA_13/20/1.15

XA_15赋值:XA_14*0.55+1日前的XA_14*0.33+2日前的XA_14*0.22

XA_16赋值:XA_15的3日指数移动平均

XA_17赋值:XA_16<100

XA_18赋值:统计9日中满足XA_17的天数<2

XA_19赋值:收盘价/1日前的收盘价>1.09

XA_20赋值:收盘价=最高价

XA_21赋值:1日前的XA_19 AND 1日前的XA_20

ZA_22赋值:统计11日中满足XA_21的天数>0

ZA_23赋值:收盘价的3日简单移动平均

ZA_24赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100

ZA_25赋值:(最高价-1日前的收盘价)/1日前的收盘价*100

XA_26赋值:1日前的10日内成交量(手)的最高值

XA_27赋值:收盘价的20日简单移动平均

XA_28赋值:(ZA_23+XA_1)/2

XA_29赋值:统计30日中满足统计1日中满足ZA_24>9.9ANDCLOSE=最高价的天数>=1的天数>0

XA_30赋值:统计60日中满足统计1日中满足ZA_24>9.9ANDCLOSE=最高价的天数>=1的天数>0

XA_31赋值:XA_27>1日前的XA_27 AND 成交量(手)<XA_26 AND XA_29 AND ZA_25>3 AND 开盘价<=XA_1 AND 收盘价>XA_1 AND (统计3日中满足XA_28>1日前的XA_28的天数>=3 OR 统计3日中满足XA_1>1日前的XA_1的天数>=3) AND 统计25日中满足XA_27>1日前的XA_27的天数>=16

XA_32赋值:(收盘价-开盘价)/开盘价*100

XA_33赋值:XA_30 AND 成交量(手)<1.3*1日前的成交量(手) AND 统计6日中满足XA_32>0.5的天数>=5 AND 统计5日中满足ZA_23>XA_1的天数>=5 AND 统计6日中满足最高价>1日前的最高价的天数>=5 AND ZA_25>4.5 AND 开盘价<=ZA_23 AND 收盘价>ZA_23 AND 开盘价>XA_1

XA_34赋值:XA_31 OR XA_33

BA_35赋值:XA_34=1 AND 统计15日中满足XA_34的天数=1

BA_36赋值:成交额(元)/成交量(手)/7

BA_37赋值:(3*最高价+最低价+开盘价+2*收盘价)/7

XA_38赋值:成交额(元)的10日累和/BA_36/7

XA_39赋值:以成交量(手)/XA_38为权重BA_37的动态移动平均

XA_40赋值:(收盘价-XA_39)/XA_39*100

XA_41赋值:-XA_40

XA_42赋值:XA_40>XA_41

XA_43赋值:XA_40上穿0.6 AND XA_42

JA_44赋值:收盘价/1日前的收盘价的5日指数移动平均

DA_45赋值:收盘价/1日前的收盘价的10日指数移动平均

NA_4G赋值:JA_44上穿DA_45

XA_47赋值:XA_43 AND NA_4G

XA_48赋值:XA_47 AND BA_35

XA_49赋值:统计10日中满足BA_35的天数>0

XA_50赋值:XA_47 AND XA_49 AND ZA_22

XA_51赋值:XA_47 AND ZA_22 AND CA_11

XA_52赋值:XA_48 AND ZA_22

XA_53赋值:XA_50 OR XA_52 OR XA_51

XA_54赋值:(收盘价的12日指数移动平均-收盘价的26日指数移动平均)/收盘价的26日指数移动平均*100

XA_55赋值:XA_54的9日指数移动平均

XA_56赋值:(XA_54-XA_55)*100

XA_57赋值:XA_56-1日前的XA_56

XA_58赋值:XA_57上穿50

CA_59赋值:收盘价的12日指数移动平均的12日指数移动平均的12日指数移动平均

OA_60赋值:(CA_59-1日前的CA_59)/1日前的CA_59*100

MA_61赋值:OA_60的9日简单移动平均

XA_62赋值:OA_60>MA_61

XA_63赋值:收盘价/1日前的收盘价>1.09

XA_64赋值:收盘价=最高价

XA_65赋值:1日前的XA_63 AND 1日前的XA_64

XA_66赋值:统计4日中满足XA_65的天数>0

XA_67赋值:统计5日中满足XA_65的天数>0

XA_68赋值:(3*收盘价+最低价+开盘价+最高价)/6

XA_69赋值:(20*XA_68+19*1日前的XA_68+18*2日前的XA_68+17*3日前的XA_68+16*4日前的XA_68+15*5日前的XA_68+14*6日前的XA_68+13*7日前的XA_68+12*8日前的XA_68+11*9日前的XA_68+10*10日前的XA_68+9*11日前的XA_68+8*12日前的XA_68+7*13日前的XA_68+6*14日前的XA_68+5*15日前的XA_68+4*16日前的XA_68+3*17日前的XA_68+2*18日前的XA_68+20日前的XA_68)/210

XA_70赋值:XA_69的6日简单移动平均

XA_71赋值:XA_69>XA_70

XA_72赋值:收盘价>1.02*1日前的收盘价

XA_73赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100<(-6)

XA_74赋值:1日前的收盘价>(上次XA_72距今天数日前的收盘价+上次XA_72距今天数+1日前的收盘价)/2 AND 收盘价<(上次XA_72距今天数日前的收盘价+上次XA_72距今天数+1日前的收盘价)/2

XA_75赋值:1日前的收盘价<(上次XA_73距今天数日前的收盘价+上次XA_73距今天数+1日前的收盘价)/2 AND 收盘价>(上次XA_73距今天数日前的收盘价+上次XA_73距今天数+1日前的收盘价)/2

XA_76赋值:上次XA_73距今天数<=7 AND XA_72 AND XA_75 AND 统计上次XA_73距今天数日中满足XA_72的天数=1 AND 取反 AND 上次XA_73距今天数日前的取反=1

XA_77赋值:统计7日中满足XA_76的天数>0

XA_78赋值:((收盘价-1日前的收盘价的6日简单移动平均)/6+收盘价的6日简单移动平均)*1.004

XA_79赋值:收盘价上穿XA_78 AND XA_78>1日前的XA_78

XA_80赋值:((收盘价-1日前的收盘价的18日简单移动平均)/18+收盘价的18日简单移动平均)*1.004

XA_81赋值:收盘价上穿XA_80 AND XA_80>1日前的XA_80

XA_82赋值:XA_79 AND XA_81 AND XA_76 AND XA_71 AND XA_62

XA_83赋值:XA_66 AND XA_76 AND XA_71 AND XA_62

XA_84赋值:XA_82 OR XA_83

XA_85赋值:XA_18 AND XA_53

XA_86赋值:XA_84 OR XA_85

当满足条件XA_86时,在0和5位置之间画柱状线,宽度为3,0不为0则画空心柱.,画淡洋红色

当满足条件XA_86时,在0和5位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画黄色

当满足条件XA_86时,在3.5位置书写文字,画黄色,线宽为2

当满足条件XA_86时,在2.5位置书写文字,画黄色,线宽为2

程序源码

XA_1:=MA(CLOSE,5);

XA_2:=MA(CLOSE,10);

XA_3:=MA(CLOSE,60);

XA_4:=MA(CLOSE,120);

XA_5:=REF(CLOSE,1)<REF(XA_1,1) AND OPEN<XA_1 AND XA_1>XA_4;

XA_6:=REF(XA_5,1)=0 AND XA_5;

XA_7:=EMA(HHV(HIGH,1),8);

XA_8:=EMA(CLOSE,8);

XA_9:=XA_8<REF(XA_8,1) AND CLOSE<XA_8;

CA_10:=IF(XA_7<REF(XA_7,1) OR XA_9,1,0);

CA_11:=(COUNT(CA_10=1,4)=3 AND CA_10=0)*89;

CA_12:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

CA_13:=IF(CLOSE>OPEN,CA_12*(HIGH-LOW),IF(CLOSE<OPEN,CA_12*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-CA_12*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-CA_12*(HIGH-LOW),0-VOL/2));

XA_14:=CA_13/20/1.15;

XA_15:=XA_14*0.55+REF(XA_14,1)*0.33+REF(XA_14,2)*0.22;

XA_16:=EMA(XA_15,3);

XA_17:=XA_16<100;

XA_18:=COUNT(XA_17,9)<2;

XA_19:=CLOSE/REF(CLOSE,1)>1.09;

XA_20:=CLOSE=HIGH;

XA_21:=REF(XA_19,1) AND REF(XA_20,1);

ZA_22:=COUNT(XA_21,11)>0;

ZA_23:=MA(CLOSE,3);

ZA_24:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

ZA_25:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;

XA_26:=REF(HHV(VOL,10),1);

XA_27:=MA(CLOSE,20);

XA_28:=(ZA_23+XA_1)/2;

XA_29:=COUNT(COUNT(ZA_24>9.9 AND CLOSE=HIGH,1)>=1,30)>0;

XA_30:=COUNT(COUNT(ZA_24>9.9 AND CLOSE=HIGH,1)>=1,60)>0;

XA_31:=XA_27>REF(XA_27,1) AND VOL<XA_26 AND XA_29 AND ZA_25>3 AND OPEN<=XA_1 AND CLOSE>XA_1 AND (COUNT(XA_28>REF(XA_28,1),3)>=3 OR COUNT(XA_1>REF(XA_1,1),3)>=3) AND COUNT(XA_27>REF(XA_27,1),25)>=16;

XA_32:=(CLOSE-OPEN)/OPEN*100;

XA_33:=XA_30 AND VOL<1.3*REF(VOL,1) AND COUNT(XA_32>0.5,6)>=5 AND COUNT(ZA_23>XA_1,5)>=5 AND COUNT(HIGH>REF(HIGH,1),6)>=5 AND ZA_25>4.5 AND OPEN<=ZA_23 AND CLOSE>ZA_23 AND OPEN>XA_1;

XA_34:=XA_31 OR XA_33;

BA_35:=XA_34=1 AND COUNT(XA_34,15)=1;

BA_36:=AMOUNT/VOL/7;

BA_37:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

XA_38:=SUM(AMOUNT,10)/BA_36/7;

XA_39:=DMA(BA_37,VOL/XA_38);

XA_40:=(CLOSE-XA_39)/XA_39*100;

XA_41:=-XA_40;

XA_42:=XA_40>XA_41;

XA_43:=CROSS(XA_40,0.6) AND XA_42;

JA_44:=EMA(CLOSE/REF(CLOSE,1),5);

DA_45:=EMA(CLOSE/REF(CLOSE,1),10);

NA_4G:=CROSS(JA_44,DA_45);

XA_47:=XA_43 AND NA_4G;

XA_48:=XA_47 AND BA_35;

XA_49:=COUNT(BA_35,10)>0;

XA_50:=XA_47 AND XA_49 AND ZA_22;

XA_51:=XA_47 AND ZA_22 AND CA_11;

XA_52:=XA_48 AND ZA_22;

XA_53:=XA_50 OR XA_52 OR XA_51;

XA_54:=(EMA(CLOSE,12)-EMA(CLOSE,26))/EMA(CLOSE,26)*100;

XA_55:=EMA(XA_54,9);

XA_56:=(XA_54-XA_55)*100;

XA_57:=XA_56-REF(XA_56,1);

XA_58:=CROSS(XA_57,50);

CA_59:=EMA(EMA(EMA(CLOSE,12),12),12);

OA_60:=(CA_59-REF(CA_59,1))/REF(CA_59,1)*100;

MA_61:=MA(OA_60,9);

XA_62:=OA_60>MA_61;

XA_63:=CLOSE/REF(CLOSE,1)>1.09;

XA_64:=CLOSE=HIGH;

XA_65:=REF(XA_63,1) AND REF(XA_64,1);

XA_66:=COUNT(XA_65,4)>0;

XA_67:=COUNT(XA_65,5)>0;

XA_68:=(3*CLOSE+LOW+OPEN+HIGH)/6;

XA_69:=(20*XA_68+19*REF(XA_68,1)+18*REF(XA_68,2)+17*REF(XA_68,3)+16*REF(XA_68,4)+15*REF(XA_68,5)+14*REF(XA_68,6)+13*REF(XA_68,7)+12*REF(XA_68,8)+11*REF(XA_68,9)+10*REF(XA_68,10)+9*REF(XA_68,11 )+8*REF(XA_68,12)+7*REF(XA_68,13)+6*REF(XA_68,14)+5*REF(XA_68,15)+4*REF(XA_68,16)+3*REF(XA_68,17)+2*REF(XA_68,18)+REF(XA_68,20))/210;

XA_70:=MA(XA_69,6);

XA_71:=XA_69>XA_70;

XA_72:=CLOSE>1.02*REF(CLOSE,1);

XA_73:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<(-6);

XA_74:=REF(CLOSE,1)>(REF(CLOSE,BARSLAST(XA_72))+REF(CLOSE,BARSLAST(XA_72)+1))/2 AND CLOSE<(REF(CLOSE,BARSLAST(XA_72))+REF(CLOSE,BARSLAST(XA_72)+1))/2;

XA_75:=REF(CLOSE,1)<(REF(CLOSE,BARSLAST(XA_73))+REF(CLOSE,BARSLAST(XA_73)+1))/2 AND CLOSE>(REF(CLOSE,BARSLAST(XA_73))+REF(CLOSE,BARSLAST(XA_73)+1))/2;

XA_76:=BARSLAST(XA_73)<=7 AND XA_72 AND XA_75 AND COUNT(XA_72,BARSLAST(XA_73))=1 AND NOT(HIGH=LOW) AND REF(NOT(HIGH=LOW),BARSLAST(XA_73))=1;

XA_77:=COUNT(XA_76,7)>0;

XA_78:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;

XA_79:=CROSS(CLOSE,XA_78) AND XA_78>REF(XA_78,1);

XA_80:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;

XA_81:=CROSS(CLOSE,XA_80) AND XA_80>REF(XA_80,1);

XA_82:=XA_79 AND XA_81 AND XA_76 AND XA_71 AND XA_62;

XA_83:=XA_66 AND XA_76 AND XA_71 AND XA_62;

XA_84:=XA_82 OR XA_83;

XA_85:=XA_18 AND XA_53;

XA_86:=XA_84 OR XA_85;

STICKLINE(XA_86,0,5,3,0),COLORLIMAGENTA;

STICKLINE(XA_86,0,5,0.5,0),COLORYELLOW;

DRAWTEXT(XA_86,3.5,' ★主力'),COLORYELLOW,LINETHICK2;

DRAWTEXT(XA_86,2.5,' ★短线'),COLORYELLOW,LINETHICK2;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

热点资讯

相关资讯

Powered by 炒股杠杆软件-股票如何操作杠杆 @2013-2022 RSS地图 HTML地图

Copyright 站群系统 © 2009-2029 联华证券 版权所有